Our technicians are looking into reports of problems in Memsource Cloud - projects seem to be inaccessible
Incident Report for Memsource
Resolved
The system is back to normal.
Posted 5 months ago. Feb 01, 2018 - 14:31 CET
Identified
Our technicians are working on a fix. Sorry for the inconveniences!
Posted 5 months ago. Feb 01, 2018 - 14:30 CET
Investigating
We are currently investigating this issue.
Posted 5 months ago. Feb 01, 2018 - 14:21 CET