Our technicians are looking into reports of degraded performance of cloud and web editor.
Incident Report for Memsource
Resolved
The Cloud and Web Editor are back to normal. We apologise for any inconveniences caused.
Posted 9 months ago. Oct 24, 2017 - 12:12 CEST
Investigating
We are currently investigating this issue.
Posted 9 months ago. Oct 24, 2017 - 11:43 CEST