Delayed or undelivered emails
Incident Report for Memsource
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 09, 2017 - 21:33 CET
Monitoring
Our email provider informed us they are having issues with the APIs Memsource is using to send out notifications. Some emails may be delayed or undelivered.
We are sorry for the complications, we will update you on any progress in their efforts.
Posted about 1 year ago. Mar 09, 2017 - 19:07 CET