New job creation takes long time
Incident Report for Memsource
Resolved
Job creation back to normal.
Posted 7 months ago. Dec 12, 2017 - 14:22 CET
Investigating
Our technicians are now looking into an issue affecting the creation of new jobs.
Posted 7 months ago. Dec 12, 2017 - 13:37 CET