Memsource Web Editor downgraded performance
Incident Report for Memsource
Resolved
The Memsource Web Editor issue has been resolved.
Posted 11 months ago. Mar 29, 2017 - 15:40 CEST
Investigating
We are looking into reports of degraded performance of Memsource Web Editor. Please use the desktop Memsource Editor if you are experiencing any issues access the Web Editor.
Posted 11 months ago. Mar 29, 2017 - 15:16 CEST