Memsource Web Editor downgraded performance
Incident Report for Memsource
Resolved
The web editor is now back to its full health.
Posted 11 months ago. Jun 19, 2017 - 12:38 CEST
Investigating
Please use the desktop Memsource Editor if you are experiencing any issues when opening jobs in the Web Editor.
Posted 11 months ago. Jun 19, 2017 - 12:20 CEST