Our technicians are investigating the degraded performance of Memsource Cloud.
Incident Report for Memsource
Resolved
Memsource Cloud and Web Editor are now back to their full health.
Posted 10 months ago. Sep 25, 2017 - 16:55 CEST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Sep 25, 2017 - 16:30 CEST