Slow import of MS Word files
Incident Report for Phrase (formerly Memsource)
Resolved
Our technicians were able to resolve the issue and imports of MS Word documents should be back to normal.
Posted May 30, 2018 - 08:33 CEST
Investigating
Customers have reported slow import of MS Word files. Our technicians are already looking into the issue.
Posted May 30, 2018 - 07:50 CEST
This incident affected: Memsource TMS (EU) (Project Management).