We are looking into reports of slower performance in Memsource Cloud
Incident Report for Phrase (formerly Memsource)
Resolved
Memsource Cloud is now recovering. All processes affected today, such as file imports, analyses and pre-translation, should be back to the normal speed.
Posted May 09, 2018 - 15:45 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 09, 2018 - 13:06 CEST
Investigating
Some users are reporting slower performance of Memsource Cloud. Our team is currently looking into this.
Posted May 09, 2018 - 10:26 CEST
This incident affected: Memsource TMS (EU) (Project Management).