Degraded performance of Memsource Components
Incident Report for Phrase (formerly Memsource)
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 19:38 CET
Monitoring
Memsource developers quickly identified the issue and a fix is being implemented. The performance should be back to normal now and we are going to keep monitoring the situation.
Posted Nov 22, 2019 - 19:33 CET
Investigating
Some users are reporting problems with importing jobs and performing some actions in Memsource. We are currently investigating the issue.
Posted Nov 22, 2019 - 19:21 CET
This incident affected: Memsource TMS (EU) (API, Editor for Web, Project Management).