Degraded Performance of Memsource Components
Incident Report for Memsource
Resolved
This incident has been resolved.
Posted Nov 30, 2019 - 13:10 CET
Update
We were able to resolve problems with degraded performance of Memsource components.
Posted Nov 30, 2019 - 13:00 CET
Investigating
Due to the recent maintenance, Memsource components experience degraded performance. We are already working on improvements and will post updates here.
Posted Nov 30, 2019 - 12:20 CET
This incident affected: SLA (Memsource Web, Memsource Editor for Web, API).