Slow Performance of Memsource Cloud
Incident Report for Phrase (formerly Memsource)
Resolved
The incident has been resolved. Memsource Cloud should now be fully operational again.
Posted Mar 27, 2019 - 15:21 CET
Investigating
Some users have reported performance issues in Memsource Cloud. Our engineers are looking into this and we will let everyone know when we know more.
The issue may affect the speed of creating new jobs (uploading files) and running analyses.
Posted Mar 27, 2019 - 15:13 CET
This incident affected: Memsource TMS (EU) (Project Management).