Slower performance of Memsource Cloud
Incident Report for Memsource
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 16, 2018 - 12:18 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Oct 16, 2018 - 11:11 CEST
Investigating
Some users have reported performance issues in Memsource Cloud. Our engineers are looking into this and we will let everyone know when we know more.
Posted 10 months ago. Oct 16, 2018 - 10:34 CEST
This incident affected: Web App and Web Editor.