Web Editor Maintenance
Incident Report for Phrase (formerly Memsource)
Resolved
This incident has been resolved.
Posted May 15, 2018 - 15:46 CEST
Investigating
Some users may observe occasional temporary errors while working in Web Editor. This is due to the ongoing maintenance. If you get an error message while working in Web Editor, please retry - repeat the action. We apologise for any inconveniences.
Posted May 15, 2018 - 12:53 CEST
This incident affected: Memsource TMS (EU) (Editor for Web).