Disruption of Memsource Components
Incident Report for Phrase (formerly Memsource)
Resolved
The developers have identified and quickly fixed the cause of the problem and the incident has been resolved. There were two short downtimes: 2:11-2:16 PM and 3:33-3:36 PM CET.
Posted Sep 10, 2019 - 16:17 CEST
Investigating
Memsource users have reported performance issues of all Memsource components. We are looking into the matter and will soon update everyone.
Posted Sep 10, 2019 - 16:09 CEST
This incident affected: Memsource TMS (EU) (API, Editor for Web, Project Management).