Degraded performance of Memsource Editor for Web
Incident Report for Phrase (formerly Memsource)
Resolved
This incident has been resolved.
Posted Aug 18, 2019 - 10:51 CEST
Monitoring
Performance should be back to normal, we are still monitoring our system to ensure the problems do not occur again.
Posted Aug 18, 2019 - 10:38 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 18, 2019 - 10:29 CEST
Investigating
We are currently investigating issues related to slow performance of Memsource Editor for Web.
Posted Aug 18, 2019 - 10:19 CEST
This incident affected: Memsource TMS (EU) (Editor for Web).