Memsource Web Editor downgraded performance
Incident Report for Memsource
Resolved
The issue of Memsource Web Editor downgraded performance has been resolved. Please reload your jobs to continue with your work.
Posted about 1 year ago. Jun 08, 2017 - 15:46 CEST
Investigating
Please use the desktop Memsource Editor if you are experiencing any issues when opening jobs in the Web Editor.
Posted about 1 year ago. Jun 08, 2017 - 13:48 CEST