Our technicians are investigating degraded performance of Memsource Cloud and Web Editor
Incident Report for Memsource
Resolved
Memsource Cloud and Web Editor are now back to their full health.
Posted about 1 year ago. Jul 11, 2017 - 09:47 CEST
Identified
There seems to be a connectivity issue on the side of our data centre. We are working to resolve the problem.
Posted about 1 year ago. Jul 11, 2017 - 09:18 CEST
Investigating
We have received reports that Memsource Cloud may not be accessible from some locations. Please contact us on support@memsource.com if this is the case. Thank you.
Posted about 1 year ago. Jul 11, 2017 - 09:15 CEST