Our technicians are investigating degraded performance of Memsource Cloud
Incident Report for Memsource
Resolved
This incident has been resolved.
Posted 12 months ago. Aug 22, 2017 - 12:48 CEST
Monitoring
Memsource Cloud should soon be back to its normal health.
Posted 12 months ago. Aug 22, 2017 - 12:27 CEST
Identified
The current issue also seems to affect Memsource Cloud. Working hard on a fix.
Posted 12 months ago. Aug 22, 2017 - 11:39 CEST
Investigating
We are looking into reports of degraded performance of Memsource Web Editor. Please use the desktop Memsource Editor if you are experiencing any issues access the Web Editor.
Posted 12 months ago. Aug 22, 2017 - 11:30 CEST