We are looking into reports of slow file imports
Incident Report for Phrase (formerly Memsource)
Resolved
The incident was resolved. We are very sorry for the inconvenience.
Posted May 03, 2018 - 17:03 CEST
Identified
We have identified the cause of the problem and are working on a fix. Sorry for the inconveniences.
Posted May 03, 2018 - 15:15 CEST
Investigating
We are currently investigating problems affecting new file imports.
Posted May 03, 2018 - 14:55 CEST
This incident affected: Memsource TMS (EU) (Project Management).