Jobs cannot be opened in the Web Editor.
Incident Report for Memsource
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 13, 2018 - 14:21 CEST
Investigating
There is a problem with opening jobs in Web Editor. Our developers are investigating the issue.
Please use Desktop Editor in the meantime.
We are very sorry for the inconvenience.
Posted 10 months ago. Apr 13, 2018 - 13:49 CEST